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Streams Rules Check: Overview 
  
The Streams Rules Check functions allow you to define DFF and DRC Rules check 
schemes for reuse across multiple printed circuit board designs.  The Streams 
Rules Check capability allows you to combine DFF rule checks, DRC rule checks, 
CAM350 macros and various utility operations to create batch schemes for 
verifying manufacturing rules for printed circuit boards. The Streams Rules 
check provides advanced human interface support for drag-and-drop rules setup, 
and results review.  
 
For Streams Rules check, each DFF/DRC rules scheme is called a Stream. A Stream 
contains one or many groups of layer type checks. A layer type check contains 
multiple predefined checks that are relevant for that specific layer type. Layer 
type checks supported in Streams Rules Check include: Signal Layer, Positive 
Plane, Negative Plane, Solder Mask, Silkscreen, and NC Data Layer.  In addition, 
special checks for Any Layer type and Netlist Comparison checks are supported. 
Design independent rules specification allows you to define consistent rules 
that will work independently of the number of layers and layer types in your 
design. 
 

Command Sequence: 
Create a new Stream from the main Streams Rule Check dialog using the View > 
Streams Rules Check command.  
Use the Streams List dialog to add new Stream. You can manage existing Streams 
and global Streams options from the Streams List dialog. Setup the Stream in the 
Checks Tab of the Stream dialog that is docked to the bottom of the application 
window.  Create the Stream definition by adding Layer type checks on the Checks 
Tab and then selected the detailed check parameters in the Details Tab.  The 
Details Tab allows you to enable or disable check routines that are available 
for a layer type check. 
 
Note: You can use the Areas Tab to specified named areas that can be reused for 
restricted rules checks in any Layer type check specified in your Stream. 
 
Run the Stream in the Checks Tab of the Streams dialog by selecting one of the 
execution choices from the Run icon drop-down list.  
You can run the Stream by:  
(1) Running the Stream definition per the Stream definition without parameter          
modification  
(2) Running the Stream on the area inside the printed circuit board border.  
(3) Running the Stream on the entire world (CAM350 workspace)  
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(4) Running the Stream on a user specified window to be interactively specified 
at runtime. 
 
Analyze the results of the Stream execution using the Results Tab in Stream 
dialog. The Results Tab stores the error information for each execution that was 
run. The Results Tab organizes the Execution results in tree navigation style by 
date/time of execution, layer check type and check routine type. When selecting 
error(s), the graphics window zooms to the associated layout region and 
highlights the selected error(s). Use the Chart icon to display a histogram of 
the selected errors. On the chart, mouse over display and right mouse bottom 
commands support error analysis. Use the command Info > Report > Streams Results 
to display a report of execution results. 
 

View > Streams Rules Check 
  
View > Streams Rules Check opens the Streams List top level dialog. The Streams 
List dialog manages the Stream DFF/DRC rules schemes that are defined in the 
current database. 
 
Note: The View > Streams Rules Check command toggles the visibility of the 
Streams List dialog on and off. 
 
Command Sequence: 
Select View > Streams Rules Check.  
In the Streams List dialog, select an existing or add a new Stream Rules Check 
for DFF/DRC scheme, using the Add Stream icon. 
 
Once selected, a Stream can be deleted using the Delete Stream icon. 
 
Once selected, a Stream can be made visible in a Stream tab dialog using by 
clicking on the "Eye" visibility icon to the left of the Stream name. 
 
To rename a Stream, double click on the system defined Stream name and type in 
the new desired name. 
In the Streams List dialog, you can save all defined Streams to an external 
file, using the Export Streams icon. You can import Streams from an external 
file, using the Import Streams icon.  
To set global Streams Rules Check options, click the Options tab at the bottom 
of the Streams List dialog. 
 
To reset the column order for the Stream Results tab output, check the Reset 
Loaded Column Order checkbox. If unchecked, any customized column order will be 
retained for Streams Results tab output. 
 
To animate selected regions during check area definition, check the Animate 
Selected Areas checkbox. 
 
To set the default docking location of the Stream tabbed dialog, click in the 
"Value" column cell for the Stream Default Placement row. Then select the 
docking location from the drop-down list. 
 
To set the maximum number of detected errors per Stream execution, click in the 
"Value" column of the Max Errors to Find row and type the desired maximum error 
limit. 
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Creating a Stream 
  
A Stream is a set of layer type checks that test your design against 
manufacturing rules. Stream Rule checks can be specified in a design independent 
manner so that a Stream can be reused across many design files. Creating a 
Stream consists of two main steps.  First, create and name a Stream in the top 
level Streams List dialog.  Second, set up the layer type checks and technology 
specific manufacturing parameters for the desired check routines. 
 
Command Sequence: 
Create a new Stream from the main Streams Rule Check dialog using the View > 
Streams Rules Check command. Use the Streams List dialog to add new Stream. Make 
the Stream visible by selecting the "Eye" icon at the left of the new Stream 
row. The Stream tabbed dialog appears at the bottom of the application window. 
 
Tip: You can manage existing Streams and global Streams options from the Streams 
List dialog. 
Add Layer Type checks to your new Stream using the Add New Check icon in the 
Checks Tab.  Layer types supported include: Signal Layer, Positive Plane, 
Negative Plane, Solder Mask, Silkscreen, and NC Data Layer.  In addition, 
special checks for Any Layer type and Netlist Comparison checks are supported. 

   
 
A Layer Type check groups check routines for DFF and DRC checks that are 
commonly used for that specific layer type. 
 
Tip: Double click in the Name cell of the newly added Stream to rename the layer 
type check. 
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Tip: The sequence of check execution is based on the order of checks in the 
Check Tab. You can easily reorder the sequence by dragging and dropping existing 
layer type checks. 
 
CAM350 macro scripts and Pause commands can be added to the Stream execution 
flow. 
 
Save your Stream definition to an external file using the Export Stream icon in 
the Checks Tab. Use the Import Stream icon to import a preexisting Stream 
definition from an external file. 
 
Tip: From the Stream Lists dialog (View > Streams Rules Check), all Streams in a 
design can be exported or imported from an external file. 
Set up your Check routine parameters using the Details Tab in the Stream tabbed 
dialog. In the Details Tab, layer types are grouped in tree navigation style. 
Specify layer type check parameters by clicking on the Value column of the 
desired row. 
 
Tip: Click the green arrow to toggle the enabled status for a layer type check 
or to toggle the enabled status for an individual Check routine. 
 
Name - Click in the Value cell and enter a new name for the layer type check. 
Layers - Click in the Value cell and click on the ellipsis ("...") at the right 
in the Value cell to open the layer selection dialog; specific design layers are 
listed first, followed by generic layer types that are useful for design 
independent Stream setup. 
Drill Layers - Click in the Value cell and click on the ellipsis ("...") at the 
right in the Value cell to open the layer selection dialog; specific design 
layers are listed first, followed by generic layer types that are useful for 
design independent Stream setup. 
DFF Checks - This is a non-editable summary of the enabled Check routines for 
this layer type check. 
DCODE Filter - Click in the Value cell and click on the ellipsis ("...") at the 
right in the Value cell to open the DCODE filter dialog. Use the drop-down list 
to select the layers from which Dcodes are listed, and then select the desired 
DCODEs for this layer type check.  
NC Tool Filter - Click in the Value cell and click on the ellipsis ("...") at 
the right in the Value cell to open the NC Tool filter dialog. Select the 
desired NC Tools for this layer type check.  
Check Region - Click in the Value cell and click on the ellipsis ("...") at the 
right in the Value cell to open the Area Selection dialog. From predefined 
regions, select positive and negative regions to create the composite area for 
which check routines are run for this layer type check.  See Stream Area Check 
Regions for more details. 
Auto Fix Errors - Check the Auto Fix Errors checkbox to enable automatic fixing 
of DFF errors that can be programmatically fixed. 
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Details - This is a Tree Navigation style list of Check routines available for 
the layer type check.  See Stream Rules Checks for details of available check 

 
  
 

Stream Check Routines 
  
The following Check routines are available for Streams Rules Check layer type 
checks: 
 
Signal Layer 
Track to Track, Track to Pad, Pad to Pad, Pad to Drill, Minimum Track, Minimum 
Pad, Unplated Drills to Copper, Plated Drills to Copper, Copper to One-Up-
Border, Redundant Pads, Plated Drills without Pads, Pads without Drills, 
Antennas, Minimum Gap, Minimum Width, Acid Traps, Copper Slivers, Pin Holes 
Positive Plane 
Plated Drills to Copper, Unplated Drills to Copper, Pads to Drills, Acid Traps, 
Copper Slivers, Pin Holes, Minimum Gap, Minimum Width 
Negative Plane 
Plated Drills to Copper, Unplated Drills to Copper, Pads to Drills, Copper to 
One-Up-Border, Isolated Thermal, Starved Thermal, Thermal Conflict, Tie Width 
Soldermask 
Pad to Mask, Drill to Mask, Mask Slivers, Soldermask Bridge, Pin Holes, 
Soldermask to Track, Missing Soldermask 
Silkscreen 
Silkscreen to Soldermask, Minimum Soldermask Width 
NC Data Layer 
Overlapping Hits, Coincidental Hits, Redundant Hits, Drill to Drill, Imploded 
Arcs, Imploded Path, Mill Tab Errors 
Netlist Compare 
Import External Netlist, Extract CAM Netlist, Run Netlist Compare 
   

Check Descriptions: 
SIGNAL LAYER AND POSITIVE PLANE CHECKS 
Track to Track - The minimum distance required between adjacent traces. 
Track to Pad - The minimum distance required between a trace and pad. 
Pad to Pad - The minimum distance required between adjacent pads. 
Pad to Drill - Annular Ring - Checks that the pad provides an annular ring 
around the drill hole size of the amount specified. 
Minimum Track - The minimum width allowed for a trace. 
Minimum Pad - The minimum size allowed for a pad. 
Unplated Drills to Copper - Checks to see if any naked unplated drills come too 
close to any copper data (traces, planes, etc) on the selected copper layer(s). 
Plated Drills to Copper - Checks to see if any naked plated drills come too 
close to any copper data (traces, planes, etc) on the selected copper layer(s). 
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Copper to One-Up-Border - The minimum distance between copper and the board 
outline. 
Redundant Pads - Checks for superimposed pads. 
Plated Drills without Pads - Checks to see if any naked plated drills exist on 
the layer(s) selected. 
Pads without Drills - Checks to see if there are any through hole pads lacking 
drills on the selected drill layer(s). 
Antennas - Checks that all trace end points are overlapping flashed pads. 
Minimum Gap - Checks for minimum gaps between copper areas, including same 
polygon and voids areas. 
Minimum Width - Checks for minimum width for all coppers areas, including traces 
and poured areas. 
Acid Traps - Checks for locations where acid will be trapped causing over 
etching. 
Copper Slivers - Checks for narrow copper areas that will likely flake off. 
Pin Holes - Checks for tiny voids in copper areas that cause acid traps or photo 
resist flaking. 
  
NEGATIVE PLANE CHECKS 
Plated Drills to Copper - Checks to see if any naked plated drills come too 
close to any copper data (traces, planes, etc) on the selected negative plane 
layer(s). 
Unplated Drills to Copper - Checks to see if any naked unplated drills come too 
close to any copper data (traces, planes, etc) on the selected negative plane 
layer(s). 
Pads to Drills - Annular Ring - Checks that the pad provides an annular ring 
around the drill hole size of the amount specified. 
Copper to One-Up-Border - The minimum distance between copper on the negative 
plane and the board outline. 
Isolated Thermal - Checks that each plane connection to the copper plane is 
valid, or has been constricted by adjacent data so that it is isolated from the 
rest of the plane layer. 
Starved Thermal - Checks that each thermal connection to the copper plane is 
valid, or has been constricted by adjacent data that is too close. 
Thermal Conflict - Checks to determine if any padstack is tied to more than one 
negative plane. 
Tie Width - Checks to determine if any thermal relief tie is too small. 
  
SOLDERMASK CHECKS 
Pad to Mask - Annular Ring - Checks that the mask layer provides an annular ring 
around the pad of the amount specified. 
Drill to Mask - Annular Ring - Checks that the mask provides an annular ring 
around the drill hole size of the amount specified. 
Mask Slivers - Checks for narrow soldermask layer areas that will likely flake 
off. 
Soldermask Bridge - Checks for mask openings that uncover copper that is too 
close together that may cause bridging during soldering. 
Pin Holes - Checks for tiny voids in copper areas that cause photo resist 
flaking. 
Soldermask to Track - Checks solder masks against electrical layers to detect 
for areas where a mask opening may expose a trace if the stencil shifts. 
Missing Soldermask - Checks that SMT pads on the selected layer(s) have 
soldermask openings. 
  
SILKSCREEN CHECKS 
Silkscreen to Soldermask - Checks that the silkscreen does not interfere with 
the opening of the solder mask layer. 
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Minimum Silkscreen Width - Checks for silkscreen features for too narrow line 
width. 
  
NC DATA LAYER CHECKS 
Overlapping Hits - Checks for two drill hits that touch (have no clearance 
between them). 
Coincidental Hits - Checks for two or more drill hits (of the same size) in the 
same location, but made by different tools. 
Redundant Hits - Checks for two or more drill hits in the same location, by the 
same tool. 
Drill to Drill - Checks the minimum distance allowed between two drill hits. Any 
drill hits closer than this distance will be flagged. 
Imploded Arcs - Checks for a radius in a mill path that is smaller than the mill 
tool is able to cut. 
Imploded Path - Checks for a path that is too narrow for the tool, and crosses 
over itself. 
Mill Tab Errors - Checks for segments that are shortened by compensation to the 
point where the mill tab will no longer fit. 
 

  

Running a Stream 
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The Checks Tab has a Run icon (green icon) that displays a drop down list of the 
four available options to execute the Stream Rules check.   
The Run option executes the Stream as defined using Check Region definitions in 
the Stream Details specification.   
The Run One-Up Border option executes the Stream only with the region defined by 
the printed circuit border, ignoring the Check Region definitions for the 
Stream.   
The Run Entire option executes the Stream on the entire CAM350 world space, 
ignoring the Check Region definitions for the Stream.  
The Select and Run option executes the Stream on an interactively defined 
rectangular window, ignoring the Check Region definitions for the Stream. 
 

Area Check Regions 
  
Area Check Regions can be defined and used for restricting regions where Stream 
Rules checks are tested. The Areas Tab on the Stream docked dialog allows users 
to create areas and name them for later identification and use in layer type 
checks. Check Regions are defined as rectangle regions or by the printed circuit 
border.   
 
In the Check Region row of a layer type check, you can combine defined areas in 
composites (positive or negative polarity) to create complex regions for which 
Stream Rules check are executed. 
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Analyzing Stream Results 
 
The Results Tab in the Stream docked dialog display the detected errors for 
Stream execution.  The results for multiple executions of a Stream are retained 
and labeled by date and time. The results are displayed in tree navigation 
style, grouped by execution time, layer check type and check routine type.  You 
can select errors in the navigation tree by selecting one or multiple errors, or 
by selecting one or more of the grouping headers above the errors.  The context 
menu is invoked with right mouse button and implements commands to delete, set 
ignore status, auto fix or comment errors. Deleted errors are hidden from list, 
display and report processing.  Errors with ignore status are not detected in 
succeeding executions of the same Stream. Fixes can be made to some of the error 
types detected by the Stream. Comments can be added to errors for documentation 
of error processing. 
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The Histogram Chart invokes the histogram dialog for that displays a summary for 
the selected errors. The X axis shows groups errors based on the value of the 
error distance. The Y axis shows the number of errors in the groups. Mouse over 
dialogs display a summary of the error in each histogram bar, including error 
type, error distance and error count per distance. You can select errors by 
clicking on a histogram bar. The context menu invoked using the right mouse 
button implements commands on the selected errors of a histogram bar. 
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The Stream Results Report can be used to display, sort, save or print Stream 
Rules check results.  
 
 

 


